common

Excel заметки

Проверка соответствия части ячейки определенному тексту:

=ЕСЛИ(ЕЧИСЛО(ПОИСК($Q$1;A2));"OK";"HE OK")

Извлечение последнего слова из текста

Итоговая формула:

=ПРАВСИМВ(A1;ДЛСТР(A1)-НАЙТИ("*";ПОДСТАВИТЬ(A1;" ";"*";ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";"")))))

Как и в предыдущей задаче, можно обернуть в ЕСЛИОШИБКА, чтобы верно работало с ячейками, в которых только 1 слово.

=ЕСЛИОШИБКА(ПРАВСИМВ(A1;ДЛСТР(A1)-НАЙТИ("*";ПОДСТАВИТЬ(A1;" ";"*";ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";"")))));A1)
Афоризм дня:
Лучшая доля не в том, чтобы воздерживаться от наслаждений, а в том, чтобы властвовать над ними, не подчиняясь им. (597)

Leave a reply